Bought a Western Digital 2TB HD but it won't read...:(

  • Hello, I bought SABRENT USB 3.0 to SATA External Hard Drive Lay-Flat Docking Station for 2.5 or 3.5in HDD, SSD [Support UASP and 20TB] (EC-DFLT) and it worked fine on all my 500GB Western Digital External Drives but not on my new 2TB Western Digital External Drive ( unformatted ).

    So, i Downloaded the Firmware Update as suggested and restarted Windows 7 but the Drive still not showing up.  What i am missing here ?... Thanks.

  • @EDGAR ALEGRE Do you mean internal drive? If external and shucked, be sure it is capable of working that way. Also make sure the drive is with 512B (512e) and not 4KB (4Kn) sectors. See if the drive shows up in Disk Management and, if not, check that it's not assigned to a pool in Storage Spaces. Will pass this on.


      I have the same issue...    the WD_Black SN850X starts out fine, but after about 10 seconds the whole thing crashes and the blue lights on it starting flashing non-stop.   I have to power cycle the dock and the process repeats itself.     

    The SSD works fine when connected directly to the MB.  My 3.5" HDD (also WD_Black) works great when it's in the dock by itself, but as soon as I insert the SSD, the problems start.

    After a little research, this seems to be a VERY common problem only with the WD brand SSDs inside of the Sabrent dock!   The brand of MB doesn't seem to matter, the type of dock (powered or not), which USB port it's plugged into, etc., etc....   the common thread throughout every complaint is that it's always the WD SSD.

Please login to reply this topic!