4-bay dock either painfully slow or crashes Mac depending on cable

  • New owner of a lovely 4-bay dock that I really want to love. It is loaded with (2) 8T and (1) 4T SSDs and connected to my 2023 Mac Mini. The mini has (4) Thunderbolt 4/USB 4 ports on it as well as (2) USB-A ports. I am using a combination of the built-in System Report Tool and the Blackmagic Disk Speed Test as tools for diagnostics.

    The short version is that if I connect my drive bay (directly) to the Mac using a USB-C cable the drive bay shows up as a USB 2.0 hub (480 Mb/s max transfer rate) but tests out at 28 Mb/s read and write. If I connect the drive bay (directly) to the mac using a Thunderbolt cable, it shows up as a USB 3.1 connection (10 Gb/s max transfer rate) and tests out at over 3000 Mb/s read and write - until is quickly crashes the system. This is consistent behaviour over multiple iterations of cables, cable types (USB-A, USB-A to USB-C, USB-C to USB-C, Thunderbolt) and ports on the Mac. 

    I know the drive bay doesn't run Thunderbolt, but Thunderbolt is backwards compatible with USB variants. I would love the speed I see with this connection, but it consistently hard reboots my Mac within 1-5 minutes with every variation I have tried of this connection. USB 3 would be almost as good, but only the Thunderbolt of the supplied cable with USB-A to USB-C adapter show the drive bay as having a USB 3 connection....and then it crashes. 

    Conversely, even the 480 Mb/s USB-A connection, while a waste of the SSDs, would be far superior to the less than 30 Mb/s I am seeing now. Interesting that the only USB-A connection that tested at near the USB-A speed limit was the too short cable provided with the dock - which show 400 Mb/s reads and writes. However, using that cable either in a USB-A or USB-c connection (with the provided adapter) eventually caused the Mac to reboot. 

    I am at a real loss. I have never seen a disk drive hard crash a system, but this has happened consistently. I also don't understand why the drive bay is showing up a such a dumbed down version of USB either when plugged into USB-A ports (rated at 5 Gb/s on my system) or the USB-C ports via an adapter.

    I normally assume hardware is not the problem, but I am running out of options. 


  • @Lee Zimmerman Let me know specifically which 4-bay unit/product you are referring to and we will try to reproduce the issue in the office.

  • My bad, should have given you that info up front - DS-SC4B.

    I did find a actual marked as "super speed" USB-C to USB-C cable this morning and tried that. I got the higher (USB 3.1) connection speed, but when I tried to run a speed test on one of the drives it repeatedly unmounted. Another data point, upgraded this system to MacOS 14 this morning. So, have seen the same behavour under MacOS 13 and 14. 

  • @Lee Zimmerman If it happens to one drive specifically, it could be a drive issue. If it's any drive, it could be a power supply/adapter issue. With a proper USB-C to USB-C cable and attached specifically to a USB 10Gbps port it should function without any issues. We are going to test this unit here to be sure it's not a compatibility issue.

  • It is multiple drives that are failing. All three drives work fine at the very slow USB 2 speed they are connected right now. I tried with just one drive powered on the other day when I was testing different connections and that didn't make any difference. I would assume (recognizing the danger of that) that powering three SSD drives isn't that much of a load on a power supply that I expect was designed to handle four spinning drives. 

    I have a different SSD (in a single enclosure) plugged into one of the Mac's Thunderbolt ports and it works fine. I even tried the drive enclosure plugged into that specifid port with no different result. 

    I am having a hard time resolving the two different behavours I am seeing:

    1) USB C connection at USB 3.x speeds causes the system to (I assume) kernal panic and reboot,

    2) USB A connection at USB 2.x speed not running at anywhere near the speed it should (except with a couple cables, including the one you suppled) and those result in the disks ejecting or the system crashing.

    It is interesting that my Mac hardware analysis software seems to imply that there is both USB 3.x and USB 2.x hubs in your enclosure and it picks which one is used based on the connection. 

  • @Lee Zimmerman We tested it on multiple Mac M1 and M2 systems. We were able to get full performance out of multiple HDDs at once. Plenty of power as tested. So I'm not sure if you have a bad unit/cable/supply and apologize for that. I recommend hitting up customer/technical support including to get a replacement if necessary. Internally we use USB 3.2 Gen 2x1 controllers like VL822 + ASM235CM, it may be possible to identify these with software.

  • Thought I would provide an update for those following along...

    Sabrent was good about RMAing the initial quad drive dock and that process was fairly painless. I bought one of the Sabrent USB C dual drive units so I could keep my system running in the meantime. That dock worked flawlessly - full 500+ MBps speeds, no random disk ejects and no kernel panic reboots. 

    The replacement 4 bay dock showed up a couple days ago and, initially, looked great. Using the high quality Apple USB C/Thunderbot cable I saw all three drives in the dock connected to a reported USB 3.1 controller capable of 10 Gbps. Initial speed/stress tests on my Samsung SATA SSDs (4T/8T)looked good - sustained 560/530 Mbps data transfer. However, as the day progress, I had one drive that started random ejecting. Then when I tried to test or do disk repairs on that drive first my system would take 5-10 minutes to recognize the drive and, once I started stressing it, kernel panic reboot. Also, that drive was constantly being access - even when it wasn't doing anything - and keepig the dock from going to sleep and turning off the fan.  

    I thought that one SSD drive must be corrupt or maybe that one bay in the drive dock was bad. Multiple iterations of starting the Mac in Recovery Mode and trying to run Disk First Aid on the drive in different bays all resulted in failures. 

    However, when I took that drive and put it back into the dual drive dock, Disk First Aid ran and said the disk was fine, the system booted and immediately recognized that drive and it has run fine for hours. 

    The other two SSDs in the quad enclosure seem to be working ok, but at this point, having spent many hours trying to get this to work right, I'm not feeling comfortable that it is a reliable solution. I did order a second one of the Sabrent USB C dual drive docks and will see if I can get all three drives working reliably with that combination. That has the other advantage of being silent! The quad enclosure fan isn't *that* loud, but it is noticeable and that was one reason I got rid of its predecessor external drive enclosure was the noise of the spinning drives. Silence is nice.

  • @Lee Zimmerman I appreciate the follow-up. We'll have to investigate this particular compatibility issue. We are always moving forward with updated products but this might be a known issue or there might be a workaround we can discover. For example, on Linux it's sometimes necessary to invoke quirk to fix USB-related power or access issues. Knowing the dual-drive unit works is good information, too. We have had feedback about noise so we do incorporate that into our designs at this stage.

Please login to reply this topic!