Unable to run True Image or Update Firmware


  • I downloaded the Acronis True Image for Sabrent, and it says this when launching:

     

    I have the Rocket 4 Plus 2TB drive connected to my system using a ROG Strix Arion USB enclosure. The drive has been initialized. So, I tried downloading the firmware update. Issue #1 - the link listed is broken. I had to search for the firmware update manually on the Sabrent website. No big deal.

    Issue #2 - when I run the firmware update, after is scans for disks for a while, I see no Sabrent drives listed. Instead, it just lists the ROG Strix Arion device, as seen here:

    What am I doing wrong? Are your utilities just incompatible with this ROG Strix Arion enclosure? If so, what specific enclosure do I need to be able to update my firmware and access the True Image software?

     



  • @tfulcher Thank you for pointing out the software issue. I am passing this information on. The link used to go to a download list for our firmware/updates but this is accessible per-drive now via the respective product page.

    Our Acronis True Image is an OEM version of the software and only works with specific drives as listed. This is to keep it from unlicensed use. Your drive is supported, but the software has to verify that it is which is not always possible through an enclosure. This is because enclosures use a USB pass-through bridge chip.

    This is also true with the firmware updater, however the Upgrade Tool is based on Phison's firmware updater which is supposed to detect and list the enclosure rather than the drive. It can still update this way in many cases. Your drive may not need updated. You can check the current firmware revision in CrystalDiskInfo. The current version is RKT4P1.2. The ideal way to update firmware is always directly as it reduces the chance of fatal disconnections during firmware updating.


  • @Sabrent   I have a similar problem. I have the simple EC-SSHD  USB to SATA adapter. I have used your Acronis software before successfully possibly before 2021 to clone a ssd device for an upgrade.   Today 12-30-2023 I tried it again for a different computer with a samsung 850 EVO ssd.  At first, I got the "check your firmware error cannot find sabrent device error, --try firmware upgrade".

    I downloaded the firmware upgrade and installed via JMS583_FWUpdate_Utility_v1_0_0_8.exe. as recommended in Sabren Support. After running 2x . 2nd time I got "the product is up to date" message.    I assume the firmware fix took OK.   But did not help !!  ReRan Acronis  it  still did not find sabrent device and said "update firmware" error message again.  Can You help me. ** The Product is not working as advertised.  Thanks.

     

     


  • Hello. I am having very similar issues. I purchased a Rocket 4 Plus for use with my PS5 and I'm getting significantly slower than advertised speeds. I heard I might need to update the firmware to fix this problem, so I bought a Sabrent enclosure. With that, I was able to format the drive and my Windows PC recognizes it. However, none of the Sabrent software, including the Control Panel and the Firmware Update, will recognize the drive. They show no drives available. What suggestions do you have?


  • After trying many solutions, it appears the problem has only gotten worse.  Now my PC will not even recognize the Sabrent enclosure, nor is it providing any power to it.  As a first time buyer of your products, I am very disappointed in my experience thus far. 

    a) Your Rocket Plus 4's read speed was significantly under what was advertised (4600 MB/s compared to advertised 7000 MB/s) when installed in my PS5.

    b) Your software wouldn't recognize the above drive when attempting to install the firmware using the Sabrent USB 3.2 Type C enclosure, which may have fixed the above slow speeds.

    c) After fully updating my PC and trying again to run the firmware and control panel, my USB-C port shut down entirely, neither providing power nor connecting any device through that port, such that I had to uninstall and reinstall all drivers and software associated with the USB-C port several times.

    d) Now that my USB-C port is finally working again for my other devices, your drive in your enclosure is now the only device that will neither connect nor receive power from the USB-C port.

    I expect a response within 24 hours or I will be returning each of these products, will cease doing business with your company, and will be leaving negative reviews on major websites.


  • And the problems continue.  Now, after getting my USB-C port back up and running for other devices, plugging in your enclosure and drive shut it down.  Again.


  • @Matt L The PS5 benchmark is not a good indicator of performance. It's common for drives to get in the 5 GB/s range, that is normal, although environmental conditions such as heat can make this worse. The drive may not be recognized through an enclosure since it acts as a SCSI device. Certain USB ports can cause issues if they deliver insufficient power. If you cannot test the drive internally, with a free M.2 slot or PCIe adapter, then I recommend returning the drive. The enclosure can be tested without a drive inside to see if it also now has issues powering and connecting and if so should also be returned.


Please login to reply this topic!