EC-SNVE Disconnects & Internal Issue

  • I've been using your M.2 enclosure with one of your own SSD's. I have a 512GB Rocket installed. The issues I have are that the drive keeps disconnecting unexpectedly (and I have its USB controller set not to sleep via Windows) and I've also noticed since installing it that there is what appears to be, a melting or distortion on the heat wicking pad inside the enclosure that matches the label of the SSD itself. Do you have any suggestions?


  • @Rick Raborn If the enclosure is getting sufficient power, this is an issue that requires either a firmware update or an RMA. There may also be a problem with the cable. The thermal result is normal.

  • @Rick Raborn I was looking at some specs and noticed this enclosure had an update so was looking for a changelog and found this post. What staff should have told you is that the bronze thing is a sticker over the purple thermal pad, remove the sticker and then close the unit. It does not seem to be the squishy kind that molds to the ssd but it still makes contact with it and will transfer heat better without the sticker. It dropped Temps about 3 degrees idle on a 970 Evo plus 2TB. The case also got noticeably warmer.

  • Hi - is there any update on this? I have the same enclosure (EC-SNVE) bought from Amazon in Nov last year and have been having random disconnection issues.

    I updated the device's firmware from the product page, I also updated the firmware of the NVME drives I've tested with it (Samsung 970 EVO 500GB and WD Blue SN570 2TB). I found afterwards that the disconnections were still taking place. I've not had any issues with the heat pad though.

    I did consider that it could be an issue with the connecting cable - I'm not using the supplied one as I only have USB-A ports avialble to test with. I've been using a UGREEN branded one and when it's worked it's been great. USB 3.2 gen1 transfer speeds of 850MBs while working.

    I've now invested in a meatier cable (Amazon purchase, SUNGUY branded USB 3.1 gen2 USB-A to USB-C) and also a USB-C to USB-A adaptor to use in conjunction with the cable supplied with the device. I'll feed back on testing but wondered if there were any other suggestions?

  • @Ben S I would contact technical support to see if they have special firmware for you to try. If there are no power delivery issues and you can confirm it does this on multiple host machines, even following any FW supplied, I would request an RMA. If it's only that machine with this issue, use of 5 Gbs speeds is recommended.

  • I have been using a 4T SSD in the M.2 EC-SNVE enclosure since April.  It is being formatted as the Time Machine disk of MacBook Pro.  Its regularly connected to the laptop but function few seconds every hour.  Last week the LED light stopped glowing but the disk still function.  Six hour s ago it worked one last time and now does not show up in the Finder.  How do I know if it is the enclosure problem or a SSD problem?  Thank you.

  • @harrry Leong The easiest way is to try another drive in the enclosure or to try the same drive in another enclosure or PC. You can also check to see if the enclosure/drive is showing up under System Information. Usually the LED will go out if the drive is not detected properly. Try plugging in the enclosure with the SSD removed to see if the LED returns.

Please login to reply this topic!