Unable to update the firmware of my Sabrent Rocket Q 500

  • Sabrent Rocket Control Panel (v1.01b)
    Sabrent Rocket Q 500 NVMe SSD (SB-RKTQ-500   FIRMWARE: RKT30Q.1)

    The "Sabrent Rocket Control Panel" software cannot check for firmware updates.
    I always get the same error: "Network error. Check your firewall". 
    Through a custom proxy, I could see that the program tries to get the RKT30Q.xml file at the address "".

    The file in question does not exist (your server replies with a 404 error).

    Can you fix your backend?
    Alternatively, can you provide me the RKT30Q.xml file and the relative firmware (.bin file)?

    Thank you.

  • @Luca M This is being investigated, thank you.

  • Same issue here, I even allowed the app through my firewall manually and still nothing.

  • This is still happening for me as well (1tb version, also currently RKT30Q1 firmware). The target XML file appears to no longer be at the target location. Is there any update on this issue or any alternate way to apply a firmware update?

  • @Tycen Hopkins @krujh1 I did report this as I personally was not able to find a workaround but I have not been updated on the matter. I will have to check in again this week.

  • @Sabrent Two months later, downloaded the latest version of the control panel from https://sabrent.com/pages/control-panel, and am getting the same Network Error issue. Has there been any update on this?

  • @Tycen Hopkins Thank you for the feedback. I will follow up on my report on this as it should have been fixed by now. I'm not sure that model had a firmware update but this is nevertheless a bug.

  • Just also downloaded this and am receiving the same error. I have the model SB-ROCKET-2TB


  • @Crowy I've sent this thread along. Apparently there were concerns with firmware corrupting the drive unexpectedly but the software is still pointing to the address.

  • I'm trying to update firmware on my SB-ROCKET-1TB and the control panel app is still broken. It seems this has been an issue for 2 years now according to this Reddit thread (https://www.reddit.com/r/thinkpad/comments/n5skhr/sabrent_rocket_control_panel_connection_error/). That's pretty excessive and I shouldn't have to do that riduculous work-around of hosting my own web server to update my SSD firmware. This seems like a really easy fix (replace hard-coded IP with URL). Does Sabrent not employ software developers anymore?

  • @Chris I will re-report this. I was informed that some models did not require an update, and for others the update could lead to corruption, so the files were pulled and this was not fixed as a high priority, but it is understandable annoying.

  • @Sabrent hey sabrent the problem has appeared again, im on the same firmware as the original poster RKT30Q.1

  • @k9pro2.0 We're back from the weekend. Thank you for the report. Some models of this drive do not require a firmware update at all. Our error could be more informative about this.

  • @Sabrent Ok, so maybe it just doesnt need a update? Its still telling me that there is a conncetion error and to check my firewall.

  • @k9pro2.0 The IP is hardcoded but because the update can cause corruption we have it removed. Your drive should not require any update.

  • 2024... It looks like nothing has changed...
    "Some models of this drive do not require a firmware update at all"
    Which models? Where do we find this list of models?

    A brand with an excellent reputation in hardware and with software that looks like it came straight from the 90s.

  • @Marcelo Silva I have forwarded this and other threads to our programmer. If a firmware update is required, we may add it to the product's website, as with the Rocket 2230.

Please login to reply this topic!