‎EC-DFLT: 4096 Bytes sector problem - firmware update

  • Dear Sabrent Team,

    I recently purchased the Sabrent USB3.0 to SATA External Hard Drive Docking Station  ‎EC-DFLT-DE (I reckon this is the German version of the ‎EC-DFLT) via Amazon. My goal was to use the Sabrent Docking Station ‎EC-DFLT to copy all the data from my 4 TB Samsung SSD 860 QVO in my laptop to my newly purchased Samsung SSD 870 QVO 8 TB, since I had reached the capacity limit of my 4 TB SSD and wanted to replace it with the 8 TB SSD. So far so good, copying over the data using the Sabrent EC-DFLT worked nicely and I was getting ready to replace the 4 TB SSD in my laptop with the 8 TB version. 

    It turned out however, that the 8 TB SSD replacement would be shown in the Windows 10 disk management with the wrong size indicated and the partition appeared as a "GPT Protective Partition". After spending quite some time on the internet to figure out, what was the problem, I ultimately found the culprit, namely the JMicron controller of the Sabrent enclosure. Modern HDD/SSD nowadays all have 4096 Byte sectors but emulate sector sizes of 512 Bytes using Advanced Format 512e for backwards compatibility. Unfortunately, the JMicron controller of Sabrent ‎EC-DFLT changes the reported size for drives >2TB back to 4096 Bytes (this allows for larger MBR formatted disks, but the controller also does it for GPT formatted ones).

    The problem described above has the undesirable effect, that a hard drive that has been formatted in the Sabrent ‎EC-DFLT cannot be used in a laptop/desktop without reformatting (and losing all data), since this back-translation to 4096 Bytes is usually not done in laptops/desktops. Similarly, HDD/SSDs that have been formatted in a normal laptop/desktop cannot be used in the Sabrent ‎EC-DFLT without reformatting (and again losing all data), since they are formatted to use 512e and not 4096 Bytes sectors, as the Sabrent ‎EC-DFLT does. I have confirmed all these observations directly: as mentioned above, the 8TB SSD formatted in the Sabrent ‎EC-DFLT cannot directly be used in my laptop (without re-formatting). The 4 TB I had formatted with my laptop and which I put into the Sabrent ‎EC-DFLT to test above observations, can also not be used (without re-formatting). fsutil shows me that the 8 TB formatted by the Sabrent ‎EC-DFLT displays a 4096 Bytes sector size, while the 4 TB I formatted with my laptop displays a 512 Bytes sector size.

    After having established the cause of my problem, I was about to return the Sabrent ‎EC-DFLT since I absolutely need an enclosure which I can use to format and write on drives which later might be put in another machine (and vice versa). However, I came across the following post, which suggested, that a firmware update could alleviate the above problems:

    I found two firmware updates on the support page of Sabrent EC-DFLT (https://sabrent.com/collections/enclosures/products/ec-dflt), but before proceeding with the firmware update, I had a few questions, since the Sabrent support forum mentioned, that there are versions of the Sabrent EC-DFLT with different SATA-USB controller chips:
    1) Will these firmware updates solve my problem?
    2) Using USB Device Tee Viewer I determined that my Sabrent EC-DFLT uses a JMicron chip (Vendor ID: 0x152D) with the Product ID: 0x1561. Are the firmwares available on the support webpage the correct ones to use (my understanding was that this firmware was for the JMicron chip JMS578, which would have the Product ID: 0x0578? -> see: https://sabrent.com/community/xenforum/topic/84781/ec-dflt)?

    I would really like to keep Sabrent ‎EC-DFLT since otherwise I am happy with the enclosure. But the above-mentioned problem is a dealbraker for me - if I cannot get around this issue, I will have to return the unit.

    Thank you for your help!

  • @Isab Your research seems to be thorough and accurate. It's my understanding that we have a firmware that will let you read drives formatted on a normal laptop/desktop in the EC-DFLT which must be requested from customer service. If you have sent a message there your issue should be handled pretty soon. 

  • Thank you very much! I am currently in contact with customer service and I think we are close into getting the problem solved (I will post here again, when I am certain that the issue has been solved).

  • After testing the closure a bit I can now confirm that the issue has been solved with the help of the customer service, who provided me with a new firmware. As far as I can tell, this is the firmware provided by the link in the starting post (described as "Firmware Update: To support hard drives that are over 4TB" which contains the file JMS578_PPE_v124.01.00.02.bin). But since I am not completely sure it might be best for someone who faces the same problem to contact customer support like I did.

    Note, that after the firmware update the device will no longer be reported as Sabrent by the operating system but as a generic JMicron SCSI Disk Device (the chipset used by Sabrent for this enclosure is a JMicron one). This is no problem at all, but I just wanted to mention it, since it might come as a surprise for some people.

    I might suggest to have a README or some explanatory file on the support page of the product so that customers immediately know how this problem can be fixed (= by installing the new firmware), should they encounter it.

    Thanks again to the customer support, they provided a great help for this case!

  • @Isab Glad it ended up working out for you. Thank you for the feedback, we are looking to improve this product and process!

  • @Isab @Sabrent

    The Problem with "generic JMicron SCSI Disk Device" instead of "SABRENT..." is that Acronis True Image will not work anymore so this could be a big issue for some customers!

    Sabrent needs to provide a working Firmware with TRIM and 4096 Bytes sectors (your issue) support that will also work with Acronis OEM for their devices with JMS578 chipset! Anything else is just a let down...

  • I have the same problem.  An 8GB  drive formatted on my computer long ago shows "GPT Protective Partition" in Windows 10 Disk Management.  Please send me the firmware and installation instruction. 

    Signed, New EC-DFLT owner.  gspinney@earthlink.net.

  • @Gregor Spinney We perhaps cover one issue in this blog. If you need a specific firmware update, please contact technical support.

Please login to reply this topic!